Ergebnis 1 bis 7 von 7

Thema: Sicherheitsupdates

  1. #1

    Sicherheitsupdates

    Hallo
    ich habe ein Problem und vielleicht hat ja jemand eine Lösung.

    Und zwar kann ich meine VMS nicht mehr aufrufen. Das lief ohne Probleme bis zuletzt.

    Jetzt habe ich ne Email von meinem Hoster bekommen.

    Sehr geehrte/r xxxxxx,

    Bald werden keine weiteren Sicherheitsupdates für die PHP Versionen 5.6 und 7.0 mehr veröffentlicht werden. PHP 5.6 wird am 31. Dezember 2018 und PHP 7.0 am 3. Dezember 2018 auslaufen. Die Entscheidung über die Einstellung dieser Versionen wurde von PHP.net getroffen. One.com hat keinen Einfluss auf diese Entscheidung.

    Die PHP-Version für Ihre Webseite xxxx läuft unter 5.6. Wir werden ein Upgrade auf Version 7.2 durchführen, die neuste verfügbare Version von PHP, und können Ihnen somit eine längere Supportlaufzeit gewährleisten. Die automatische Aktualisierung Ihrer PHP Version wird in der ersten Novemberhälfte stattfinden.

    Wenn das Upgrade durchgeführt wurde, können Sie vorübergehend wieder ein Downgrade auf PHP 5.6 oder 7.0 vornehmen. Nach dem 3. Dezember 2018 wird ein Downgrade jedoch nicht mehr möglich sein. Wenn Ihre Website an diesem Datum PHP 5.6 oder 7.0 verwendet, wird diese automatisch auf 7.2 aktualisiert.


    Nun die Frage , wie kann ich meine VMS mit php 7.2 zusammenarbeiten lassen ?? Hat jemand ne Idee wie ich das jetzt ändere das es wieder geht?

    Bin da ein wenig überfragt..

    Danke
    Geändert von Tulpe81 (11.11.2018 um 16:04 Uhr)

  2. #2
    Erfahrener Benutzer
    Registriert seit
    12.11.2008
    Beiträge
    1.521

    AW: Sicherheitsupdates

    Moin,
    wenn dir die Wesentliche Grundkenntnisse für ein Upgrade fehlen, würde ich dir empfehlen, auf das VMS3 zu wechseln.

    Alternativ kann auch das VMS-Suee herhalten.

    Wenn du zusätzlich Games auf deiner Seite hast und die mit Flash laufen, solltest du dir überlegen, ob es noch Sinn macht
    die Arbeit auf sich zu nehmen. Flash wird 2020 eingestellt. Danach wird es wohl noch eine zeitlang gehen, bis dann die Browser
    auch dicht machen werden. Bei Google ist das ja schon der Fall.

    LG

  3. #3

    AW: Sicherheitsupdates

    Aloha , danke für die Info. Nein Die Page nutze ich eher privat im kleinen Kreis mit dem Anteilesystem. Mehr muss das Script auch nicht können. Aber gut teste mich mal mit der 3.0er Version durch. Aber noch eine Frage , es ist das VMSone , ist dann dieses VMS-R als 3.0er Version von Dir gemeint ?? Grüße

  4. #4
    Erfahrener Benutzer
    Registriert seit
    12.11.2008
    Beiträge
    1.521

    AW: Sicherheitsupdates

    Nope, weder noch.

    Das hier im Fred, im letzten Post
    https://www.designerscripte.net/show...oX%C2%B2/page3

    Da musste wohl dem Inhaber mal ne PN schicken. Weiß nicht was da Stand ist, wegen Downloaden etc.

    Ansonsten VMS-suee.

    Glaub das VMSone, läuft nur auf PHP5.6

  5. #5

    AW: Sicherheitsupdates

    Danke für die Info. Schauen wir mal was er sagt.

  6. #6
    Neuer Benutzer Avatar von ztk.me
    Registriert seit
    13.11.2018
    Beiträge
    3

    AW: Sicherheitsupdates

    servus, was das vms Suee angeht, so glaube ich kaum, das es eine Option im derzeitigen Zustand ist. Zumindest im Git. Habe mal einen Fork aufgemacht und ein paar Patches bereit gestellt.
    Die andere Sache ist ja oft die, das man nicht ohne weiteres mal eben das Grundscript austauschen kann, Addons und Anpassungen die nicht mehr passen etc. pp.

    Im übrigen gibt es sicher noch Anbieter die PHP 5.6 sicher auch über den Tod hinaus anbieten, wenn auch mit Einschränkungen - z.B. kann keine Garantie gegeben werden, das z.B. zukünftig alle TLS-gesicherten Verbindungen ( fopen ) tadellos funktionieren werden. Aber auch dafür könnte man mit Hilfe eines "privaten, 'unsicheren' TLS/SSL-Proxy" einen workaround basteln - sofern man will.

    Eigenwerbung darf ich ja hier nicht machen und Hosting ist auch nicht gerade mein Broterwerb, aber falls Bedarf besteht, so billig wie one könnte ich leider nicht, aber preiswerter als https://strato.de/blog/strato-php-ex...-fuer-php-5-3/ ( denke ~5,33€ Aufpreis für php 5.3 wird bei 5.6 nicht viel anders werden ) definitiv.

    Ansonsten eben gucken, mit dem "normalen" VMS inkl. mysqli- bzw PDO patches dürften die meißten Addons aber kompatibel sein.

  7. #7
    Benutzer
    Registriert seit
    08.12.2006
    Beiträge
    67

    AW: Sicherheitsupdates

    oh man lach lach )

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •