Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Installation VMS 1.2 ohne Klamm - SQL Probleme

  1. #1
    Erfahrener Benutzer Avatar von swinxx
    Registriert seit
    16.09.2006
    Beiträge
    1.637

    Installation VMS 1.2 ohne Klamm - SQL Probleme

    Hey,

    wollte grad das VMS 1.2 neu installieren, aber krieg die DB einfach nicht hoch...
    Ich denke es liegt daran das es schon älter ist und meine SQL 5.5 zu neu.

    Wenn ich die SQL importiere bekomm ich gleich bei der Ersten Tabelle "vms_aktivierungen" einen Fehler...

    Also ich versuche folgendes zu adden:
    Tabellenstruktur für Tabelle `vms_aktivierungen`
    --

    DROP TABLE IF EXISTS `vms_aktivierungen`;
    CREATE TABLE `vms_aktivierungen` (
    `uid` int(7) NOT NULL auto_increment,
    `ak` varchar(32) NOT NULL default '',
    PRIMARY KEY (`uid`),
    KEY `aktivierungs_code` (`ak`)
    ) TYPE=MyISAM AUTO_INCREMENT=2 AUTO_INCREMENT=2 ;

    --
    -- Daten für Tabelle `vms_aktivierungen`
    --


    und bekomme den Fehler:


    Tabellenstruktur für Tabelle `vms_aktivierungen`
    --

    DROP TABLE IF EXISTS `vms_aktivierungen`;
    MySQL meldet: Dokumentation

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Tabellenstruktur für Tabelle `vms_aktivierungen`
    --

    DROP TABLE IF EXISTS `' at line 1


    Wenn ich den "Drop Table" Teil weglasse und nur folgendes adde:

    CREATE TABLE `vms_aktivierungen` (
    `uid` int(7) NOT NULL auto_increment,
    `ak` varchar(32) NOT NULL default '',
    PRIMARY KEY (`uid`),
    KEY `aktivierungs_code` (`ak`)
    ) TYPE=MyISAM AUTO_INCREMENT=2 AUTO_INCREMENT=2 ;

    --
    -- Daten für Tabelle `vms_aktivierungen`
    --


    bekomme ich den Fehler:


    MySQL meldet: Dokumentation

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM AUTO_INCREMENT=2 AUTO_INCREMENT=2' at line 6


    Also sry wenn ich nerve aber könnte mir da jemand helfen bzw. hätte jemand vielleicht sogar eine angepasste SQL die für ganz aktuelle SQL Versionen (falls das überhaupt das Prob ist)

    Würde mich wirklich freuen da ich dringend ein Script bräuchte auf dem ich einfach aufbauen kann und da ist das VMS für so Proggernoobs wie mich einfach spitze!

    Lg, Swinxx

  2. #2
    Erfahrener Benutzer
    Registriert seit
    12.11.2008
    Beiträge
    1.511

    AW: Installation VMS 1.2 ohne Klamm - SQL Probleme

    Moin Swinxx,
    du bekommst die Sachen nicht in die DB, weil TYPE=MyISAM veraltet ist. Du müsstest die TYPE=MyISAM mit ENGINE=MyISAM ersetzen.

    Ich würde allerdings von 1.2. ohne Klammanbindung abraten, weil du das Script so nicht mehr zum laufen bekommen wirst bzw. erst
    komplett anpassen müsstest.

    Zieh lieber die aktuellste Version vom Script (2.5.1) und pass dir das an. Das geht wesentlich schneller
    Wenn du das allein nicht hinbekommst, such dir jemanden der sich damit auskennt.

    Sam

  3. #3
    Erfahrener Benutzer Avatar von swinxx
    Registriert seit
    16.09.2006
    Beiträge
    1.637

    AW: Installation VMS 1.2 ohne Klamm - SQL Probleme

    Ok, Danke, hab mir die 2.5.1 geholt und die DB Installation hat sofort funktioniert

    Wegen dem Umbauen passt das schon, das ganze Klamm Zeug kann ja drin sein, muss es ja nicht verwenden... Alles was ich bräuchte ist die Möglichkeit sich per Usernamen einzuloggen statt mit KID und entsprechend auch die Anmeldung ohne KID. Hab das damals selber schon mal hinbekommen aber das is schon einige Jahre her und da hat mir Gremlin noch geholfen (War zu der Zeit als Gremlin und ich noch die Admins von DSN hier waren- also schon ewig her, direkt von Nebulus übernommen damals...)

    Also ich versuchs mal ob ichs hinbekomm mit dem umschreiben, vielleicht schaff ichs ja. Falls du Tipps für mich zum Umbau hast bin ich gerne für alles offen und wäre sehr dankbar Wie gesagt brauch ich nur Anmeldung und Login ohne KID.

    Wenn ich mich richtig erinnere gabs glaub ich sogar mal ein Addon das man sich mit Usernick anmelden kann, mal schauen...

    Danke auf jeden Fall schonmal für die Hilfe!

    Lg, Swinxx

  4. #4
    Erfahrener Benutzer Avatar von swinxx
    Registriert seit
    16.09.2006
    Beiträge
    1.637

    AW: Installation VMS 1.2 ohne Klamm - SQL Probleme

    Hmm, wenn ich das jetzt in der DB richtig gesehen hab gibt´s da eh kein Feld für die Klamm ID *freu*, also muss ich da anscheinend nichts ändern.

    Ich hab jetzt die Files auf den Server geladen, die config angepasst aber ich bekomm diesen Fehler:

    Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /homepages/35/d659737625/htdocs/imike/internal/lib/functions.lib.php:15 Stack trace: #0 /homepages/35/d659737625/htdocs/imike/internal/index.php(11): db_connect() #1 {main} thrown in /homepages/35/d659737625/htdocs/imike/internal/lib/functions.lib.php on line 15

    Ich habs mehrmals überprüft und die Daten für die DB Verbindung stimmen so wie ich sie eingetragen hab... Wüsste evt. jemand woran es noch liegen könnte das ich diesen Fehler bekomme? Wenn ich das richtig verstehe sagt die Fehlermeldung ja das die DB Verbindung nicht hingehauen hat?

    Naja, aber zumindest bin ich schonmal ein Stück weiter als am Anfang

    Lg, Swinxx

    *Edit* Achja, falls es was bringt: Ich hab für das VMS ein Unterverzeichniss "internal" angelegt und die URL auch richtig in der config eingetragen (also ohne Slash am Ende ist das bei mir http://www.imike.at/internal ).
    Geändert von swinxx (25.02.2018 um 21:04 Uhr)

  5. #5
    Benutzer
    Registriert seit
    05.11.2007
    Beiträge
    40

    AW: Installation VMS 1.2 ohne Klamm - SQL Probleme

    Moinsen,
    welche PHP Version verwendest du?
    Die Fehler Meldung ist eigentlich eindeutig MYSQL gibt es nicht mehr und wurde durch MYSQLI /PDO ersetzt.

    Maeggi

  6. #6
    Erfahrener Benutzer Avatar von swinxx
    Registriert seit
    16.09.2006
    Beiträge
    1.637

    AW: Installation VMS 1.2 ohne Klamm - SQL Probleme

    PHP Version verwende ich PHP 7.0.27 - Hab schnell ne neue phpinfo erstellt www.imike.at/phpinfo.php

    Wie wirkt sich diese Umstellung von MYSQL auf MYSQLI aus bzw. was sollte ich da beachten. Hoffe die Erklärung ist jetzt nicht zu umfangreich weil ich will euch hier nicht mit meinen Kiddy Problemen nerven...

  7. #7
    Erfahrener Benutzer
    Registriert seit
    12.11.2008
    Beiträge
    1.511

    AW: Installation VMS 1.2 ohne Klamm - SQL Probleme

    Ich hab eben auch mal in 2.5.1. reingeschaut. Das ist nicht PHP7 tauglich.
    Das Script müsste in diversen Punkten angepasst werden. Angefangen von der Datenbankverbindung, hinzu den mysql_querys und was dazu gehört
    und noch diverse Funktionen ersetzt bzw. erneuert werden.

    Und ich wiederhol mich da gern nochmal. Such dir jemanden der sich damit auskennt. Wenn dir die normalen Grundlagen schon fehlen, wirst
    du an diversen Stellen stolpern Nicht böse gemeint

  8. #8
    Erfahrener Benutzer Avatar von swinxx
    Registriert seit
    16.09.2006
    Beiträge
    1.637

    AW: Installation VMS 1.2 ohne Klamm - SQL Probleme

    Zitat Zitat von Sam2004 Beitrag anzeigen
    Und ich wiederhol mich da gern nochmal. Such dir jemanden der sich damit auskennt. Wenn dir die normalen Grundlagen schon fehlen, wirst
    du an diversen Stellen stolpern Nicht böse gemeint
    Hmm, ja, wird mir wohl nix anderes überbleiben denn wie du schon sagst fehlen mir da die Skills um das selber hinzubekommen. Und mit einer neuen Version des VMS, welche angepasst ist, wird wohl nicht so bald, wenn überhaupt noch, zu rechnen sein...

    Da vermisse ich doch glatt die Zeiten wo die Klammlose noch was waren. Da hätte ich jetzt einfach ein paar Mio dafür geboten, das es mir jemand anpasst und die Sache wäre erledigt gewesen Tja

    Im Forum hier is ja auch nicht mehr wirklich was los leider - also im gegensatz zu damals. Mit Gremlin hab ich keinen richtigen Kontakt mehr und sonst kenne ich auch niemanden der mir da helfen könnte... Im Klamm Forum findet man zwar immer wieder mal paar Leute die Progg-Aufträge annehmen aber meist teuer bzw. für weit mehr der blöden Klammlose als ich besitze.

    Kennst du bzw. irgendjemand hier eventuell jemanden den ich da fragen könnte. Mit "Echtgeld" schauts halt bei mir leider schlecht aus. Ich hab 30.000 Primera die ich bieten kann oder so Sachen wie Backlinks auf meiner Seite, aber sonst leider nichts...

    Also falls jmd was weiss wo ich Hilfe herbekomme wäre ich sehr dankbar. Wenn das VMS dann so angepasst ist, dass es für die neuesten PHP und SQL Versionen passt würde ich es selbstverständlich auch hier für den Downloadbereich weitergeben das auch andere was davon haben.

    LG, Swinxx

  9. #9
    Erfahrener Benutzer
    Registriert seit
    12.11.2008
    Beiträge
    1.511

    AW: Installation VMS 1.2 ohne Klamm - SQL Probleme

    Zitat Zitat von swinxx Beitrag anzeigen
    Hmm, ja, wird mir wohl nix anderes überbleiben denn wie du schon sagst fehlen mir da die Skills um das selber hinzubekommen. Und mit einer neuen Version des VMS, welche angepasst ist, wird wohl nicht so bald, wenn überhaupt noch, zu rechnen sein...

    Da vermisse ich doch glatt die Zeiten wo die Klammlose noch was waren. Da hätte ich jetzt einfach ein paar Mio dafür geboten, das es mir jemand anpasst und die Sache wäre erledigt gewesen Tja

    Im Forum hier is ja auch nicht mehr wirklich was los leider - also im gegensatz zu damals. Mit Gremlin hab ich keinen richtigen Kontakt mehr und sonst kenne ich auch niemanden der mir da helfen könnte... Im Klamm Forum findet man zwar immer wieder mal paar Leute die Progg-Aufträge annehmen aber meist teuer bzw. für weit mehr der blöden Klammlose als ich besitze.

    Kennst du bzw. irgendjemand hier eventuell jemanden den ich da fragen könnte. Mit "Echtgeld" schauts halt bei mir leider schlecht aus. Ich hab 30.000 Primera die ich bieten kann oder so Sachen wie Backlinks auf meiner Seite, aber sonst leider nichts...

    Also falls jmd was weiss wo ich Hilfe herbekomme wäre ich sehr dankbar. Wenn das VMS dann so angepasst ist, dass es für die neuesten PHP und SQL Versionen passt würde ich es selbstverständlich auch hier für den Downloadbereich weitergeben das auch andere was davon haben.

    LG, Swinxx
    Ich glaube, dass wohl auch das allgemeine Problem mit dem VMS, weil Klammlose tot sind und damit sein Zenit überschritten hat, zumindest im Betrieb mit Klammlose.
    In anderen Währungen oder auf Euro Basis wird es ja auch erfolgreich betrieben.

    Aber wohl wegen dem Wegfall bzw. der dauerhaften Inflation, wurde das VMS nicht weiter entwickelt. Auf der anderen Seite wird wohl auch die fehlende Zeit eine Rolle gespielt haben.

    Lange Rede, gar kein Sinn: Ich würde dir vorschlagen auf das Vms-suee-2-0 umzusteigen. Das läuft mit PHP7. Auch wenn das Basis Script wohl nur kostenlos ist, sollte man für mehr, mal ein paar ocken locker machen.

    Ansonsten kenn ich keinen, der weder die Zeit noch die Nerven hat das Teil umzuschreiben und hier zum Download bereit zu stellen.

    Sorry.

    Sam

  10. #10
    Erfahrener Benutzer
    Registriert seit
    22.06.2009
    Beiträge
    405

    AW: Installation VMS 1.2 ohne Klamm - SQL Probleme

    hallo,

    du hast jetzt genau 2 optionen. Entweder du nutzt das vms-suee 2.0 was noch in der beta phase ist und was ich noch immer verbesser und fehler beseitige, hast aber hier die möglichkeit die meisten addons auf den markt mit einfachen sachen auf die version anzupassen

    oder

    du nimmst das VMS was neu dazu gekommen ist von Lokultus. Das beruht komplett auf PDO. Hier hast du allerdings das Problem, das keinerlei addons mehr passen und du alle DB abfragen in den addons umschreiben musst.

Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •